hyfm.net
当前位置:首页 >> jDk11兼容jDk8吗 >>

jDk11兼容jDk8吗

可以,你需要用到jdk8的时候,更改JAVA_HOME指向jdk8的目录,需要用到jdk11的时候,指向jdk11的目录.操作系统和集成开发环境只根据JAVA_HOME环境变量寻找jdk.jdk11相对于以前的版本,分离了javaFX,如果你想要在jdk11版本下使用javaFX,需要另外下载javaFX的jar包,和其他的jar包一样,导入就可以了.

你用jdk11编译出来的.class 不能在jdk1.8运行 再看看别人怎么说的.

上官网上看 官网上有JDK 6、7、8、9、10 对应的版本就是JDK1.6、1.7、1.8、1.9、1.10 所以是JDK10版本更高 不过目前使用最多的是1.8

不可以的,一般是和jdk版本保持一致的,也就是说tomcat6用>=jdk6版本就可以了.通常情况下,可以依次类推的.tomcat8.0可以兼容jdk1.6,而tomcat6.0不可以兼容jdk1.8,tomcat版本高->jdk版本低 不会出问题

Scala 2.11.0版本在RC4版本上并未进行代码变动,主要改进了文档.此外,该版本与2.10.x系列的二进制版本不兼容.Scala 2.11.x系列主要是针对Java 6,此外,该版本对Java 8的支持主要集中在读取Java 8字节码、解析Java 8源码.

环境变量没有配置对在环境变量中增加java_home 路径为c:\program files \java\jdk1.8.0_11在系统path环境变量中增加 ;%java_home%\bin;%java_home%\jre\bin

方法/步骤1、首先,点击进入jdk官网. 2、进入官网过后,同意协议,并下载对应版本的jdk,64位电脑的下载x64的,32位电脑下载i586的. 4、在下载文件中,双击下载的可执行文件jdk-8u51-windows-x64.exe,在弹出的界面中点击“确定”,

如果安装的是最新版java则环境变量jdk1.6.0_11 修改为jdk1.7.0_51

支持的,不过版本有点高.建议用1.7或者1.6版本在window -preference --myeclipse----server ---tomcat下配置tomcat;在window -preference --java---jre下配置jdk即可.

你环境变量对应的更新了?如果没有建议检查一下,还有就是你的classpath检查下.需要修改至你安装的版本.

tongrenche.com | sbsy.net | ymjm.net | zdly.net | 369-e.com | 网站首页 | 网站地图
All rights reserved Powered by www.hyfm.net
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com